Ytel Contact Center Call Failures Thursday 26th September 2024 07:30:07 America/Los_Angeles


We are investigating reports of Call Failures effecting Ytel Contact Center

We are marking this incident as resolved. Our monitoring has concluded with no new incidents being discovered or reported.

Update 8:50 am PST: Engineers have introduced a patch to correct the matter of calls not completing and our test calls are completing as expected. We will continue to monitor and encourage you to contact Customer Support if you continue to experience call completion challenges.

Update 8:30 am PST: We continue to investigate reports of call failures impacting both inbound and outbound voice calls on the Contact Center platform.

Update 8:15 am PST: Clarification - this is affecting both inbound and outbound voice calls on the Contact Center platform

Update 8:00 PST: am this matter remains under investigation with our Engineers