Agent Latency monitoring is not displaying

Incident Report for Ytel Status Page

Resolved

Agent Latency Monitoring is now displaying as expected.
Posted Oct 23, 2025 - 13:07 PDT

Investigating

The Agent Latency monitoring tool in Contact Center is not displaying results as expected and our engineers are looking into the root cause.
Posted Oct 23, 2025 - 10:16 PDT
This incident affected: Ytel Network Infrastructure (Contact Center Agent Latency Monitoring).