Outbound Calls not completing as expected

Incident Report for Ytel Status Page

Resolved

This matter has been fully resolved. Ytel Engineers will continue to monitor through the day.
Posted Aug 28, 2025 - 09:56 PDT

Monitoring

A fix has been implemented and we are seeing calls complete as expected. We will continue to monitor.
Posted Aug 28, 2025 - 09:50 PDT

Identified

Ytel Engineers have identified the root cause and are working towards resolution
Posted Aug 28, 2025 - 09:48 PDT

Investigating

We are investigating reports of voice calls not completing as expected. This is impacting outbound, inbound, and manual dialing
Posted Aug 28, 2025 - 09:41 PDT
This incident affected: CCaaS - Contact Center - ycc.ytel.com (Voice Calls).