Ytel Contact Center Outbound Call Connections

Incident Report for Ytel Status Page

Resolved

Call connections continue to remain stable, and all systems are performing as expected. Our team will continue monitoring to ensure ongoing reliability.

Team Ytel
Posted Nov 13, 2025 - 08:41 PST

Monitoring

Call connection reporting has returned to normal, and all services are operating as expected. Our team will continue to monitor system performance to ensure stability.

Thank you for your patience while we resolved this issue.

Team Ytel
Posted Nov 13, 2025 - 07:35 PST

Investigating

We are currently receiving reports of inconsistent call connections. Our engineering team is actively investigating the issue to identify the cause and implement a resolution.

We will provide updates here as more information becomes available. Thank you for your patience.
Posted Nov 13, 2025 - 07:21 PST
This incident affected: CCaaS - Contact Center - ycc.ytel.com (Voice Calls).