Google Cloud Services – Elevated Latency effecting voice calls

Incident Report for Ytel Status Page

Resolved

Latency continues to remain within acceptable thresholds and is no longer impacting services.

Our team will continue to monitor system performance to ensure continued stability. We appreciate your patience and apologize for any inconvenience experienced during the disruption.
Posted Sep 01, 2026 - 15:17 PDT

Monitoring

The issue causing elevated latency across Outbound Calls, Inbound Calls, Webphone and Workflow appears to be resolved.

Our team is continuing to monitor the affected services to ensure stability and will provide additional updates if the issue returns.

We apologize for the inconvenience and appreciate your patience.
Posted Sep 01, 2026 - 09:15 PDT

Investigating

We are currently experiencing elevated latency due to a Google Cloud Services disruption. The following services are affected:

Outbound Calls
Inbound Calls
Webphone
Workflow

Our team is actively investigating. We will continue to provide updates as the situation develops.
Posted Sep 01, 2026 - 08:53 PDT
This incident affected: API (Voice) and CCaaS - Contact Center - ycc.ytel.com (Voice Calls).