"Forgot Password" is under maintenance

Incident Report for Ytel Status Page

Resolved

This incident has been resolved and the Forgot/Edit/Reset Password functionality has been fully restored.
Posted Sep 04, 2025 - 10:40 PDT

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 03, 2025 - 12:54 PDT

Investigating

The "Forgot/Edit Password" feature is currently offline for maintenance. If you need assistance with resetting your password, please open a support ticket. We apologize for any inconveniences this may cause.
Posted Sep 03, 2025 - 10:32 PDT
This incident affected: CPaaS - Ytel Universe - app.ytel.com (Account Management).