This incident has been resolved. We recommend all Contact Center agents logout, perform a full clear of cache and cookies, and login again to reset connectivity.
Posted Oct 24, 2025 - 08:26 PDT
Update
We have identified the issue as Hurricane Electric, one of our multiple ISP's, which we have removed from routing. This has resolved the issue and we are monitoring.
Posted Oct 24, 2025 - 08:19 PDT
Monitoring
We have identified the issue as Hurricane Electric, one of our multiple ISP's, which we have removed from routing. This has resolved the issue and we are monitoring.
Posted Oct 24, 2025 - 08:10 PDT
Identified
An internal network error is preventing Contact Center systems from being accessed, which is causing voice call failures. Our Engineers are reviewing and we will share an update as soon as we can.
Posted Oct 24, 2025 - 07:53 PDT
This incident affected: CCaaS - Contact Center - ycc.ytel.com (Contact Center Admin Portal, Contact Center Agent Portal) and Ytel Network Infrastructure (Data Center - East).