Agents unable to login and voice call degraded performance

Incident Report for Ytel Status Page

Resolved

We have resolved the incident and services are fully operational.
Posted Dec 09, 2025 - 14:45 PST

Identified

We have identified and isolated the root cause to a single server. Efforts are underway to resolve the issue.
Posted Dec 09, 2025 - 13:51 PST

Investigating

Engineers are investigating the Agent portal and voice calls not functioning for a small subset of customers.
Posted Dec 09, 2025 - 13:40 PST
This incident affected: CCaaS - Contact Center - ycc.ytel.com (Contact Center Agent Portal, Voice Calls).