Call Quality

Incident Report for Ytel Status Page

Resolved

Our monitoring is complete and this incident is resolved.
Posted Sep 09, 2025 - 22:51 PDT

Monitoring

We have made a network routing change which has resolved the matter seen throughout the day. We are currently in a monitoring period.
Posted Sep 09, 2025 - 15:58 PDT

Update

We continue to investigate this matter.
Posted Sep 09, 2025 - 14:15 PDT

Update

We continue to investigate this incident.
Posted Sep 09, 2025 - 12:33 PDT

Update

We continue to investigate this incident.
Posted Sep 09, 2025 - 11:55 PDT

Update

This matter remains under review with our Engineers
Posted Sep 09, 2025 - 11:15 PDT

Investigating

We are investigating reports of poor call quality
Posted Sep 09, 2025 - 10:49 PDT
This incident affected: CCaaS - Contact Center - ycc.ytel.com (Voice Calls).