Delayed Call recording conversion and SMS/ Call logs

Incident Report for Ytel Status Page

Identified

The issue affecting Call and SMS logs has been resolved. Log data is now fully accessible in app.ytel.

Please note that call recording conversions may still experience delays while our team is working to resolve the matter.

Thank you for your patience and understanding.
Posted Nov 12, 2025 - 08:34 PST

Investigating

We are currently experiencing delays in call recording conversions, which may result in recordings taking longer than usual to appear.
Additionally, Call and SMS logs are temporarily unavailable in app,ytel reports.

Our engineering team is actively investigating the issue and working to restore normal functionality as quickly as possible. We will provide updates as more information becomes available.

Thank you for your patience and understanding.
Team Ytel
Posted Nov 12, 2025 - 08:19 PST
This incident affects: CPaaS - Ytel Universe - app.ytel.com (Call Recording, Reporting).