Ytel Logo

System Status

Contact Center login issues affecting a small subset of users
Incident Report for Ytel, Inc.
Resolved
This incident has been resolved.
Posted 13 days ago. Sep 05, 2019 - 11:18 PDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 13 days ago. Sep 05, 2019 - 10:37 PDT
Investigating
Engineers are currently investigating reports of login challenges affecting a small subset of users
Posted 13 days ago. Sep 05, 2019 - 10:25 PDT
This incident affected: Contact Center Agent (Webphone, Multi-Channel, UI Scripting) and Contact Center Admin (Data Management, Reports, Utilities, Recordings, Billing & Payments).