Ytel Logo

System Status

Contact Center Agent Interface not functioning as expected
Incident Report for Ytel, Inc.
Resolved
This incident has been resolved.
Posted 9 days ago. Aug 14, 2019 - 10:05 PDT
Monitoring
Engineers have identified the root cause, have resolved and are currently monitoring.
Posted 9 days ago. Aug 14, 2019 - 08:45 PDT
Investigating
Engineers are investigating reports of the Contact Center Agent interface not completing or receiving calls as expected
Posted 9 days ago. Aug 14, 2019 - 08:38 PDT
This incident affected: Contact Center Agent (Webphone).