Ytel Logo

System Status

Voice Broadcast not functioning as expected
Incident Report for Ytel, Inc.
Resolved
This incident has been resolved.
Posted Nov 05, 2019 - 21:18 PST
Monitoring
We have corrected the matter and are currently monitoring
Posted Nov 05, 2019 - 09:11 PST
Investigating
Engineers are investigating reports of the Voice Broadcast service not functioning as expected
Posted Nov 05, 2019 - 08:07 PST
This incident affected: Broadcast (Voice Broadcasting).