Ytel Logo

System Status

Broadcast - Unable to Start Campaigns
Incident Report for Ytel, Inc.
Resolved
This incident has been resolved.
Posted 30 days ago. Aug 19, 2019 - 14:44 PDT
Monitoring
Campaigns are now starting as expected and test calls are completing. The Ytel team will continue to monitor the Broadcast system.
Posted 30 days ago. Aug 19, 2019 - 08:59 PDT
Investigating
We are currently investigating a matter within the Broadcast platform. Reports include the inability to start campaigns.
Posted 30 days ago. Aug 19, 2019 - 08:43 PDT
This incident affected: Broadcast (Voice Messaging User Interface).