Ytel Logo

System Status

Voice broadcast not initiating as expected
Incident Report for Ytel, Inc.
Resolved
This incident has been resolved.
Posted 5 months ago. May 24, 2019 - 13:12 PDT
Monitoring
Our Engineers have identified and have corrected the root cause. We will continue to monitor.
Posted 5 months ago. May 24, 2019 - 12:11 PDT
Investigating
Engineers are investigating reports of Voice broadcasts not initiating as expected
Posted 5 months ago. May 24, 2019 - 11:58 PDT
This incident affected: Broadcast (Voice Broadcasting).