Ytel Logo

System Status

SMS delivery delays
Incident Report for Ytel, Inc.
Resolved
This issue was isolated to a single number.
Posted 5 months ago. Mar 28, 2019 - 19:14 PDT
Investigating
We are identifying reports of delivery delays to a small subset of numbers.
Posted 5 months ago. Mar 28, 2019 - 19:07 PDT
This incident affected: Communications API (SMS).