Ytel Logo

System Status

New SMS Campaigns not running as expected
Incident Report for Ytel, Inc.
Resolved
This matter has been resolved.
Posted 5 months ago. Mar 23, 2019 - 13:52 PDT
Update
We are continuing to work on a fix for this issue.
Posted 5 months ago. Mar 23, 2019 - 12:14 PDT
Identified
We have identified the root cause
Posted 5 months ago. Mar 23, 2019 - 11:37 PDT
Investigating
Engineers are investigating reports of new SMS campaigns not running as expected
Posted 5 months ago. Mar 23, 2019 - 11:24 PDT
This incident affected: Broadcast (Ringless Voicemail Broadcasting, SMS Broadcast).