Ytel Logo

System Status

Contact Center Webphone call quality
Incident Report for Ytel, Inc.
Resolved
This incident has been resolved. Thank you for your patience.
Posted 27 days ago. Aug 22, 2019 - 11:02 PDT
Monitoring
Webphone services have been restored and we are monitoring. Please logout and login to reset your instance or contact Support if you require additional assistance.
Posted 27 days ago. Aug 22, 2019 - 10:42 PDT
Identified
We have identified instances where call quality is degraded and are taking steps to remedy. Agents may experience a loss of connectivity - this is to be expected.
Posted 27 days ago. Aug 22, 2019 - 10:18 PDT
This incident affected: Contact Center Agent (Webphone).