Ytel Logo

System Status

Ytel user portal non-responsive for some users
Incident Report for Ytel, Inc.
Resolved
This incident has been resolved.
Posted 3 months ago. May 30, 2019 - 10:06 PDT
Monitoring
The matter has been resolved and we are monitoring. We recommend you clear cache and cookies from your web browser.
Posted 3 months ago. May 30, 2019 - 08:56 PDT
Investigating
Engineers are investigating reports of limited responsiveness for some users when accessing the Ytel Portal.
Posted 3 months ago. May 30, 2019 - 08:36 PDT
This incident affected: Ytel Portal (API Explorer, Logging, Billing & Payments, Account Management, File Management).