Ytel Logo

System Status

Broadcast not completing calls as expected
Incident Report for Ytel, Inc.
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 10, 2019 - 08:59 PDT
Monitoring
Maintenance was performed and we are seeing the system perform as expected
Posted 3 months ago. Jul 10, 2019 - 08:27 PDT
Investigating
We are currently investigating reports of Broadcast not completing calls as expected
Posted 3 months ago. Jul 10, 2019 - 07:55 PDT
This incident affected: Broadcast (Audio Storage and Management, Billing & Payments, CallerID Mapping, Voice Messaging User Interface, Ringless Voicemail User Interface, Reports, Data Uploader, Ringless Voicemail Broadcasting, SMS Broadcast, Inbound Voice).