Voice calls unable to complete as expected Friday 14th August 2020 08:15:00 America/Los_Angeles


Engineers are currently investigating reports of voice calls not able to complete as expected and high agent wait times

Monitoring is complete. All systems are functioning as expected.

Engineers have corrected the matter and we are seeing calls complete as expected. We will remain in a monitoring status for the time being.

Update: This matter remains under investigation.